SPEC-3723: restructure meta-agl
[AGL/meta-agl.git] / meta-agl-core / recipes-platform / packagegroups / packagegroup-agl-profile-graphical.bb
diff --git a/meta-agl-core/recipes-platform/packagegroups/packagegroup-agl-profile-graphical.bb b/meta-agl-core/recipes-platform/packagegroups/packagegroup-agl-profile-graphical.bb
new file mode 100644 (file)
index 0000000..bfc5e19
--- /dev/null
@@ -0,0 +1,22 @@
+SUMMARY = "The middleware for AGL IVI profile"
+DESCRIPTION = "The set of packages required for AGL IVI Distribution"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+    packagegroup-agl-profile-graphical \
+    profile-graphical \
+    "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+    packagegroup-agl-image-minimal \
+    packagegroup-agl-graphical-weston \
+    packagegroup-agl-graphical-multimedia \
+"
+# FIXME: Removed due to issues building against weston 5.0.0:
+#    waltham-transmitter
+
+RDEPENDS_profile-graphical = "${PN}"