Remove systemd user session and clean up packagegroups and images
[AGL/meta-agl.git] / meta-agl-core / recipes-platform / packagegroups / packagegroup-agl-graphical-weston.bb
index 8593030..af4d90c 100644 (file)
@@ -1,17 +1,13 @@
-DESCRIPTION = "The minimal set of packages required for Wayland support"
+DESCRIPTION = "The minimal set of packages required for the Weston compositor"
 LICENSE = "MIT"
 
-inherit packagegroup
+inherit packagegroup features_check
 
-PACKAGES = "\
-    packagegroup-agl-graphical-weston \
-    "
-
-ALLOW_EMPTY:${PN} = "1"
+# weston-init requires pam enabled if started via systemd
+REQUIRED_DISTRO_FEATURES = "wayland ${@oe.utils.conditional('VIRTUAL-RUNTIME_init_manager', 'systemd', 'pam', '', d)}"
 
 RDEPENDS:${PN} += " \
-                  weston \
-                  weston-init \
-                  weston-examples \
-                  "
-
+    weston \
+    weston-init \
+    ${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)} \
+"