meta-agl-core: fix polkit dependencies
[AGL/meta-agl.git] / meta-agl-core / recipes-platform / packagegroups / packagegroup-agl-graphical-weston.bb
index af4d90c..96f09d5 100644 (file)
@@ -1,13 +1,9 @@
 DESCRIPTION = "The minimal set of packages required for the Weston compositor"
 LICENSE = "MIT"
 
-inherit packagegroup features_check
-
-# weston-init requires pam enabled if started via systemd
-REQUIRED_DISTRO_FEATURES = "wayland ${@oe.utils.conditional('VIRTUAL-RUNTIME_init_manager', 'systemd', 'pam', '', d)}"
+inherit packagegroup
 
 RDEPENDS:${PN} += " \
     weston \
     weston-init \
-    ${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)} \
 "