Remove systemd user session and clean up packagegroups and images
[AGL/meta-agl.git] / meta-agl-core / recipes-platform / images / agl-image-weston.bb
index 7e9f881..d902020 100644 (file)
@@ -1,9 +1,15 @@
 SUMMARY = "A very basic Wayland image with a terminal"
+LICENSE = "MIT"
 
-require agl-image-weston.inc
+require agl-image-minimal.bb
 
-LICENSE = "MIT"
+inherit features_check
+
+REQUIRED_DISTRO_FEATURES = "wayland"
+
+SYSTEMD_DEFAULT_TARGET = "graphical.target"
 
-IMAGE_INSTALL:append = "\
-    packagegroup-agl-profile-graphical \
-    "
+IMAGE_INSTALL += " \
+    packagegroup-agl-graphical-weston \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'weston-examples', '', d)} \
+"