Remove systemd user session and clean up packagegroups and images
[AGL/meta-agl.git] / meta-agl-core / recipes-platform / images / agl-image-minimal.bb
index 52cc06a..4e54e93 100644 (file)
@@ -1,9 +1,9 @@
 SUMMARY = "An AGL small image just capable of allowing a device to boot."
+LICENSE = "MIT"
 
-require agl-image-minimal.inc
+inherit agl-core-image
 
-LICENSE = "MIT"
+IMAGE_INSTALL = "packagegroup-agl-image-minimal ${CORE_IMAGE_EXTRA_INSTALL}"
 
-IMAGE_INSTALL:append = "\
-    packagegroup-agl-image-minimal \
-    "
+IMAGE_ROOTFS_SIZE ?= "8192"
+IMAGE_ROOTFS_EXTRA_SPACE:append = "${@bb.utils.contains("DISTRO_FEATURES", "systemd", " + 4096", "", d)}"