meta-agl-core: add Upstream-Status tag to patches
[AGL/meta-agl.git] / meta-agl-core / recipes-graphics / wayland / agl-compositor_git.bb
index 948305d..fd6d851 100644 (file)
@@ -8,11 +8,10 @@ SECTION = "x11"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=fac6abe0003c4d142ff8fa1f18316df0"
 
-DEPENDS = "wayland wayland-protocols wayland-native weston \
-          ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
+DEPENDS = "wayland wayland-protocols wayland-native weston"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "4e4624dee9850b4a4e590dd0f0f2b3173bded085"
+SRCREV = "ffdbb335ee72a5b5cba198800c5537b89d7755a0"
 AGL_BRANCH:aglnext = "next"
 SRCREV:aglnext = "${AUTOREV}"
 
@@ -26,6 +25,9 @@ PACKAGECONFIG[grpc-proxy] = "-Dgrpc-proxy=true,-Dgrpc-proxy=false,grpc grpc-nati
 
 inherit meson pkgconfig python3native
 
+# Reuse include file from upstream weston since we have the same requirements
+require recipes-graphics/wayland/required-distro-features.inc
+
 PACKAGES =+ "agl-shell-grpc-server"
 
 FILES:${PN} = " \
@@ -42,8 +44,6 @@ FILES:agl-shell-grpc-server = " \
 RDEPENDS:${PN} += " \
     agl-compositor-init \
     xkeyboard-config \
-    ${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)} \
-    ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)} \
 "
 
 FILES:${PN}-dev += " \