wayland/agl-compositor_git.bb: Bump SRCREV
[AGL/meta-agl.git] / meta-agl-core / recipes-graphics / wayland / agl-compositor_git.bb
index ccf7b88..eff1a89 100644 (file)
@@ -8,10 +8,11 @@ SECTION = "x11"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=fac6abe0003c4d142ff8fa1f18316df0"
 
-DEPENDS = "wayland wayland-protocols wayland-native weston"
+DEPENDS = "wayland wayland-protocols wayland-native weston \
+          ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "e1e8c07e202ffccc7b56f8f116a2ef1624028f91"
+SRCREV = "cec4cf8fe409cae5618e81e4a3b6dd11cc8b2aa9"
 
 PV = "0.0.10+git${SRCPV}"
 S = "${WORKDIR}/git"
@@ -22,9 +23,20 @@ PACKAGECONFIG[policy-deny-all] = "-Dpolicy-default=deny-all,,"
 
 inherit meson pkgconfig python3native
 
-FILES_${PN} = " \
-               ${bindir}/agl-compositor \
-               ${bindir}/agl-screenshooter \
-               ${datadir}/${PN}/protocols/agl-shell.xml \
-               ${datadir}/${PN}/protocols/agl-shell-desktop.xml \
-              "
+FILES:${PN} = " \
+    ${bindir}/agl-compositor \
+    ${bindir}/agl-screenshooter \
+    ${libdir}/agl-compositor/libexec_compositor.so.0 \
+    ${libdir}/agl-compositor/libexec_compositor.so.0.0.0 \
+"
+
+RDEPENDS:${PN} += " \
+    agl-compositor-init \
+    ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)} \
+"
+
+FILES:${PN}-dev += " \
+    ${datadir}/agl-compositor/protocols/agl-shell.xml \
+    ${datadir}/agl-compositor/protocols/agl-shell-desktop.xml \
+    ${libdir}/agl-compositor/libexec_compositor.so \
+"