agl-compositor_git: Bump agl-compositor SRCREV
[AGL/meta-agl.git] / meta-agl-core / recipes-graphics / wayland / agl-compositor_git.bb
index 553f3a6..d4f5ce7 100644 (file)
@@ -8,21 +8,40 @@ SECTION = "x11"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=fac6abe0003c4d142ff8fa1f18316df0"
 
-DEPENDS = "wayland wayland-protocols wayland-native weston"
+DEPENDS = "wayland wayland-protocols wayland-native weston grpc grpc-native \
+          ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "bdd8dd718496dc8e4330209c46c196442bcf7d3e"
+SRCREV = "7ef34e0c465a7596f87866e88bc5a9eed2ca7c05"
+AGL_BRANCH:aglnext = "next"
+SRCREV:aglnext = "${AUTOREV}"
 
 PV = "0.0.10+git${SRCPV}"
 S = "${WORKDIR}/git"
 
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[policy-rba] = "-Dpolicy-default=rba,,librba,librba rba-config"
 PACKAGECONFIG[policy-deny-all] = "-Dpolicy-default=deny-all,,"
 
 inherit meson pkgconfig python3native
 
-FILES_${PN} = " \
-               ${bindir}/agl-compositor \
-               ${bindir}/agl-screenshooter \
-               ${datadir}/${PN}/protocols/agl-shell.xml \
-               ${datadir}/${PN}/protocols/agl-shell-desktop.xml \
-              "
+FILES:${PN} = " \
+    ${bindir}/agl-compositor \
+    ${bindir}/agl-screenshooter \
+    ${libdir}/agl-compositor/libexec_compositor.so.0 \
+    ${libdir}/agl-compositor/libexec_compositor.so.0.0.0 \
+    ${libdir}/agl-compositor/agl-shell-grpc-server \
+"
+
+RDEPENDS:${PN} += " \
+    agl-compositor-init \
+    xkeyboard-config \
+    ${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)} \
+    ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)} \
+"
+
+FILES:${PN}-dev += " \
+    ${datadir}/agl-compositor/protocols/agl-shell.xml \
+    ${datadir}/agl-compositor/protocols/agl-shell-desktop.xml \
+    ${libdir}/agl-compositor/libexec_compositor.so \
+"