[agl-shell-activator] Decouple due to dependency on grpc
[AGL/meta-agl.git] / meta-agl-core / recipes-graphics / wayland / agl-compositor_git.bb
index eff1a89..a76da66 100644 (file)
@@ -12,7 +12,9 @@ DEPENDS = "wayland wayland-protocols wayland-native weston \
           ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "cec4cf8fe409cae5618e81e4a3b6dd11cc8b2aa9"
+SRCREV = "7ef34e0c465a7596f87866e88bc5a9eed2ca7c05"
+AGL_BRANCH:aglnext = "next"
+SRCREV:aglnext = "${AUTOREV}"
 
 PV = "0.0.10+git${SRCPV}"
 S = "${WORKDIR}/git"
@@ -20,9 +22,12 @@ S = "${WORKDIR}/git"
 PACKAGECONFIG ?= ""
 PACKAGECONFIG[policy-rba] = "-Dpolicy-default=rba,,librba,librba rba-config"
 PACKAGECONFIG[policy-deny-all] = "-Dpolicy-default=deny-all,,"
+PACKAGECONFIG[grpc-proxy] = "-Dgrpc-proxy=true,-Dgrpc-proxy=false,grpc grpc-native,grpc agl-shell-grpc-server"
 
 inherit meson pkgconfig python3native
 
+PACKAGES =+ "agl-shell-grpc-server"
+
 FILES:${PN} = " \
     ${bindir}/agl-compositor \
     ${bindir}/agl-screenshooter \
@@ -30,8 +35,14 @@ FILES:${PN} = " \
     ${libdir}/agl-compositor/libexec_compositor.so.0.0.0 \
 "
 
+FILES:agl-shell-grpc-server = " \
+    ${libdir}/agl-compositor/agl-shell-grpc-server \
+"
+
 RDEPENDS:${PN} += " \
     agl-compositor-init \
+    xkeyboard-config \
+    ${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)} \
     ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)} \
 "