weston-ini-conf: Add grpc-shell-server to no-activate ini
[AGL/meta-agl.git] / meta-agl-core / recipes-graphics / wayland / agl-compositor_git.bb
index fe565c0..948305d 100644 (file)
@@ -12,7 +12,9 @@ DEPENDS = "wayland wayland-protocols wayland-native weston \
           ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "de7cdb0314af94939b8d57e10afc2a1553ae82da"
+SRCREV = "4e4624dee9850b4a4e590dd0f0f2b3173bded085"
+AGL_BRANCH:aglnext = "next"
+SRCREV:aglnext = "${AUTOREV}"
 
 PV = "0.0.10+git${SRCPV}"
 S = "${WORKDIR}/git"
@@ -20,19 +22,31 @@ S = "${WORKDIR}/git"
 PACKAGECONFIG ?= ""
 PACKAGECONFIG[policy-rba] = "-Dpolicy-default=rba,,librba,librba rba-config"
 PACKAGECONFIG[policy-deny-all] = "-Dpolicy-default=deny-all,,"
+PACKAGECONFIG[grpc-proxy] = "-Dgrpc-proxy=true,-Dgrpc-proxy=false,grpc grpc-native,grpc agl-shell-grpc-server"
 
 inherit meson pkgconfig python3native
 
-FILES_${PN} = " \
+PACKAGES =+ "agl-shell-grpc-server"
+
+FILES:${PN} = " \
     ${bindir}/agl-compositor \
     ${bindir}/agl-screenshooter \
     ${libdir}/agl-compositor/libexec_compositor.so.0 \
-    ${libdir}/agl-compositor/libexec_compositor.so.0.0.0 \
+    ${libdir}/agl-compositor/libexec_compositor.so.0.0.21 \
+"
+
+FILES:agl-shell-grpc-server = " \
+    ${libdir}/agl-compositor/agl-shell-grpc-server \
 "
 
-RDEPENDS_${PN} += " ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
+RDEPENDS:${PN} += " \
+    agl-compositor-init \
+    xkeyboard-config \
+    ${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)} \
+    ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)} \
+"
 
-FILES_${PN}-dev += " \
+FILES:${PN}-dev += " \
     ${datadir}/agl-compositor/protocols/agl-shell.xml \
     ${datadir}/agl-compositor/protocols/agl-shell-desktop.xml \
     ${libdir}/agl-compositor/libexec_compositor.so \