Convert to new override syntax
[AGL/meta-agl.git] / meta-agl-core / recipes-graphics / wayland / agl-compositor_git.bb
index edd0ca8..79a9915 100644 (file)
@@ -12,7 +12,7 @@ DEPENDS = "wayland wayland-protocols wayland-native weston \
           ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "e1e8c07e202ffccc7b56f8f116a2ef1624028f91"
+SRCREV = "59b6881bc315388ba0c8f1be382dce1f6aed3304"
 
 PV = "0.0.10+git${SRCPV}"
 S = "${WORKDIR}/git"
@@ -23,10 +23,17 @@ PACKAGECONFIG[policy-deny-all] = "-Dpolicy-default=deny-all,,"
 
 inherit meson pkgconfig python3native
 
-FILES_${PN} = " \
+FILES:${PN} = " \
                ${bindir}/agl-compositor \
                ${bindir}/agl-screenshooter \
                ${datadir}/${PN}/protocols/agl-shell.xml \
                ${datadir}/${PN}/protocols/agl-shell-desktop.xml \
+               ${libdir}/agl-compositor/libexec_compositor.so.0 \
+               ${libdir}/agl-compositor/libexec_compositor.so.0.0.0 \
               "
-RDEPENDS_${PN} += " ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
+
+RDEPENDS:${PN} += " ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
+
+FILES:${PN}-dev += " \
+        ${libdir}/agl-compositor/libexec_compositor.so \
+"