Remove systemd user session and clean up packagegroups and images
[AGL/meta-agl.git] / meta-agl-core / recipes-graphics / wayland / agl-compositor-init.bb
index 0cdf4d5..a3127a3 100644 (file)
@@ -1,10 +1,16 @@
-SUMMARY = "Startup systemd unit drop-in file for the AGL Wayland compositor"
+SUMMARY = "Startup systemd unit for the AGL Wayland compositor"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 
+inherit systemd
+
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-SRC_URI = "file://agl-compositor.conf.in"
+SRC_URI = "file://agl-compositor.service \
+           file://agl-compositor.socket \
+           file://agl-compositor-autologin \
+           file://agl-compositor.conf.in \
+"
 
 S = "${WORKDIR}"
 
@@ -15,7 +21,14 @@ AGL_COMPOSITOR_ARGS:append = " ${@bb.utils.contains("DISTRO_FEATURES", "agl-deve
 AGL_COMPOSITOR_ARGS:append = " ${@bb.utils.contains("WESTON_USE_PIXMAN", "1", " --use-pixman", "",d)}"
 
 do_install() {
-    # Process ".in" files
+    # Install systemd service
+    install -D -p -m0644 ${WORKDIR}/agl-compositor.service ${D}${systemd_system_unitdir}/agl-compositor.service
+    install -D -p -m0644 ${WORKDIR}/agl-compositor.socket ${D}${systemd_system_unitdir}/agl-compositor.socket
+    if [ "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" ]; then
+        install -D -p -m0644 ${WORKDIR}/agl-compositor-autologin ${D}${sysconfdir}/pam.d/agl-compositor-autologin
+    fi
+
+    # Install systemd service drop-in with extra configuration
     files=agl-compositor.conf.in
     for f in ${files}; do
         g=${f%.in}
@@ -24,17 +37,22 @@ do_install() {
                 ${WORKDIR}/${f} > ${WORKDIR}/${g}
         fi
     done
-
-    # Install Weston systemd service drop-in
-    install -d ${D}${systemd_system_unitdir}/weston.service.d
-    install -m644 ${WORKDIR}/agl-compositor.conf ${D}/${systemd_system_unitdir}/weston.service.d/agl-compositor.conf
+    install -d ${D}${systemd_system_unitdir}/agl-compositor.service.d
+    install -m644 ${WORKDIR}/agl-compositor.conf ${D}/${systemd_system_unitdir}/agl-compositor.service.d/agl-compositor.conf
 }
 
 FILES:${PN} += "\
-    ${systemd_system_unitdir}/weston.service.d \
+    ${systemd_system_unitdir}/agl-compositor.service \
+    ${systemd_system_unitdir}/agl-compositor.socket \
+    ${systemd_system_unitdir}/agl-compositor.service.d \
+    ${sysconfdir}/default/agl-compositor \
+    ${sysconfdir}/pam.d/ \
     "
 
-RDEPENDS:${PN} = " \
-    agl-compositor \
-    weston-init \
-"
+CONFFILES:${PN} += "${sysconfdir}/default/agl-compositor"
+
+RDEPENDS:${PN} = "agl-users agl-compositor weston-ini"
+
+RCONFLICTS:${PN} = "weston-init"
+
+SYSTEMD_SERVICE:${PN} = "agl-compositor.service agl-compositor.socket"