Backport fix for CVE-2017-1000364 to linux-yocto-4.4
[AGL/meta-agl.git] / meta-agl-bsp / recipes-kernel / linux / linux-yocto_%.bbappend
index 6b8483e..8266f55 100644 (file)
@@ -1,8 +1,27 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/linux-yocto:"
 
 # Extra configuration options for the QEMU kernel
-SRC_URI += "file://0001-fanotify-fix-notification-of-groups-with-inode-mount.patch \
-            file://fanotify.cfg \
+SRC_URI += "file://fanotify.cfg \
             file://uinput.cfg \
             file://hid.cfg \
+            file://drm.cfg \
             "
+
+# Enable support for TP-Link TL-W722N USB Wifi adapter
+SRC_URI += " file://ath9k_htc.cfg \
+           "
+
+# Enable support for RTLSDR
+SRC_URI += " file://rtl_sdr.cfg \
+           "
+
+# disk drivers for vmdk
+SRC_URI_append_qemux86 = " file://vbox-vmware-sata.cfg "
+SRC_URI_append_qemux86_64 = " file://vbox-vmware-sata.cfg "
+
+# Fix for CVE-2017-1000364
+SRC_URI_append = " \
+file://0001-mm-larger-stack-guard-gap-between-vmas.patch \
+file://0002-Allow-stack-to-grow-up-to-address-space-limit.patch \
+file://0003-mm-fix-new-crash-in-unmapped_area_topdown.patch \
+"