Add support for CES 2017 demo hardware
[AGL/meta-agl.git] / meta-agl-bsp / recipes-kernel / linux / linux-yocto_%.bbappend
index 24bd38d..49899a4 100644 (file)
@@ -1,4 +1,20 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/linux-yocto:"
 
 # Extra configuration options for the QEMU kernel
-SRC_URI += "file://uinput.cfg"
+SRC_URI += "file://fanotify.cfg \
+            file://uinput.cfg \
+            file://hid.cfg \
+            file://drm.cfg \
+            "
+
+# Enable support for TP-Link TL-W722N USB Wifi adapter
+SRC_URI += " file://ath9k_htc.cfg \
+           "
+
+# Enable support for RTLSDR
+SRC_URI += " file://rtl_sdr.cfg \
+           "
+
+# disk drivers for vmdk
+SRC_URI_append_qemux86 = " file://vbox-vmware-sata.cfg "
+SRC_URI_append_qemux86_64 = " file://vbox-vmware-sata.cfg "