weston-ini-conf: Rework to use fragments to construct weston.ini
[AGL/meta-agl.git] / meta-agl-bsp / recipes-graphics / wayland / weston-ini-conf.bbappend
index dba2ad6..8fa08bc 100644 (file)
@@ -1,17 +1,9 @@
-# OVERRIDES save us some c'n'p below ...
-OVERRIDES_prepend_qemux86 = "customwestonini:"
-OVERRIDES_prepend_qemux86-64 = "customwestonini:"
-# intel-corei7-64 ??
-
-python() {
-    if "customwestonini" in d.getVar("OVERRIDES", True).split(":"):
-        # DRM backend disabled for now to allow compatibility with VirtualBox
-        # and VMWare Player. It may be re-enabled if running on QEMU for
-        # potentially increased performance.
-        #backend=drm-backend.so
-        d.delVarFlag("WESTONCORE", "backend")
-
-        d.setVarFlag("WESTONOUTPUT1","agl_screen", "SCREEN_QEMU")
-}
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
+# OVERRIDES save us some c'n'p below ...
+OVERRIDES_prepend_qemux86 = "virtualmachine:"
+OVERRIDES_prepend_qemux86-64 = "virtualmachine:"
 
+# Switch to the Virtual section that we have when a valid DRM device is found
+SRC_URI_remove_virtualmachine = "file://hdmi-a-1-270.cfg"
+SRC_URI_append_virtualmachine = " file://virtual.cfg"