Do not use cpio.gz for initramfs as smack does not work
[AGL/meta-agl.git] / meta-agl-bsp / meta-ti / recipes-kernel / linux / linux-ti-staging_%.bbappend
index 0c93740..b2e5431 100644 (file)
@@ -22,3 +22,12 @@ SRC_URI_append_smack = "\
        file://0004-Smack-Assign-smack_known_web-label-for-kernel-thread.patch \
 "
 
+# Enable support for smack
+KERNEL_CONFIG_FRAGMENTS_append_smack = "\
+       ${WORKDIR}/audit.cfg \
+       ${WORKDIR}/smack.cfg \
+       ${WORKDIR}/smack-default-lsm.cfg \
+"
+
+# file comes out of  meta-agl-bsp/recipes-kernel/linux/linux_%.bbappend
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/can-bus.cfg"