Add joystick.cfg for usb joystick and steering-wheel kernel configure
[AGL/meta-agl.git] / meta-agl-bsp / meta-ti / recipes-kernel / linux / linux-ti-staging_%.bbappend
index b2e5431..6a5f4f4 100644 (file)
@@ -1,3 +1,5 @@
+require recipes-kernel/linux/linux-dtb.inc
+
 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
 
 SRC_URI_append = " file://ramblock_nbd.cfg"
@@ -31,3 +33,9 @@ KERNEL_CONFIG_FRAGMENTS_append_smack = "\
 
 # file comes out of  meta-agl-bsp/recipes-kernel/linux/linux_%.bbappend
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/can-bus.cfg"
+
+# Enable support for usb video class for usb camera devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
+
+# Enable support for joystick devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"