dra7xx: weston: add patches for weston 1.11
[AGL/meta-agl.git] / meta-agl-bsp / meta-ti / recipes-arago / weston / weston_%.bbappend
index 1ceba7f..5f22fcc 100644 (file)
@@ -1,17 +1,22 @@
-#inherit append-code-change
 # When configured for fbdev compositor, make it the default
 PACKAGECONFIG[fbdev] = "--enable-fbdev-compositor WESTON_NATIVE_BACKEND="fbdev-backend.so",--disable-fbdev-compositor,udev mtdev"
 PACKAGECONFIG[kms] = "--enable-drm-compositor,--disable-drm-compositor,drm udev libgbm mtdev"
 
-PR_append = ".agl_arago_16"
+PR_append = ".agl_arago22"
 
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
 RDEPENDS_${PN} += "weston-conf"
 
+
 SRC_URI += " \
        file://0001-udev-seat-restrict-udev-enumeration-to-card0.patch \
        file://0001-Add-soc-performance-monitor-utilites.patch \
+       file://0002-Weston-Allow-visual_id-to-be-0.patch \
+       file://0003-Weston-Fix-virtual-keyboard-display-issue-for-QT5-ap.patch \
+       file://0004-Weston-Fix-touch-screen-crash-issue.patch \
+       file://0001-compositor-drm-fix-hotplug-weston-termination-proble.patch \
+       file://0001-compositor-drm-support-RGB565-with-pixman-renderer.patch \
 "
 
 RDEPENDS_${PN}_remove = "weston-conf"