meta-agl-bsp: move usbaudio.cfg to linux-agl.inc
[AGL/meta-agl.git] / meta-agl-bsp / meta-renesas / recipes-kernel / linux / linux-renesas_%.bbappend
index 368f1ba..ee4d25f 100755 (executable)
@@ -6,7 +6,6 @@ SRC_URI += " file://disable_delay_printk.patch \
              file://cfg_mac_80211.cfg \
              file://ath9k_htc.cfg \
              file://rtl_sdr.cfg \
-             file://usbaudio.cfg \
              file://ra2x00.cfg \
              file://0001-media-r820t-do-not-double-free-fe-tuner_priv-in-r820.patch \
              file://0002-media-r820t-remove-redundant-initializations-in-r820.patch \
@@ -42,3 +41,9 @@ KERNEL_CONFIG_FRAGMENTS_append_agl-porter-hibernate += " ${WORKDIR}/hibernation/
 
 # file comes out of  meta-agl-bsp/recipes-kernel/linux/linux_%.bbappend
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/can-bus.cfg"
+
+# Enable support for usb video class for usb camera devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
+
+# Enable support for joystick devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"