Revert "meta-renesas: update gstreamer version workaround"
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3-adas / recipes-kernel / linux / linux-renesas_%.bbappend
index 7ebe36a..def762b 100644 (file)
@@ -1,7 +1,9 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
-# disable the perf fix as the cogent layer contains it
-perfFIX = ""
+SRC_URI_append_ulcb = " \
+    file://0001-arm64-dts-renesas-preserve-drm-HDMI-connector-naming.patch \
+    file://disable_most.cfg \
+"
 
 KERNEL_DEVICETREE_remove_h3ulcb = " \
     renesas/r8a7795-es1-h3ulcb-view.dtb \
@@ -22,3 +24,7 @@ KERNEL_DEVICETREE_remove_h3ulcb = " \
     renesas/r8a7795-h3ulcb-4x2g-vb2.1.dtb \
     renesas/r8a7795-h3ulcb-4x2g-vbm.dtb \
 "
+
+# The meta-rcar layer actives by default the configuration MTD_RENESAS_RPC_HYPERFLASH
+# in the kernel. We need to set DISABLE_RPC_ACCESS to deactivate it.
+DISABLE_RPC_ACCESS ?= "1"