Apply the perf fix only when meta-rcar-gen3-adas is not present
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-kernel / linux / linux-renesas_%.bbappend
index 405fc97..43aeb62 100644 (file)
@@ -5,14 +5,16 @@ require recipes-kernel/linux/linux-agl.inc
 SRC_URI_append  = " file://namespace_fix.cfg \
     "
 
+# This can fix a compilation issue with perf. As this seems to collide with the cogent layer
+# we apply this here by variable and reset it when the -adas layer is present.
+perfFIX ??= " file://9999-perf-libbft-upstream.patch "
+#
+
 # Add ADSP patch to enable and add sound hardware abstraction
 SRC_URI_append_ulcb = " \
     file://0004-ADSP-enable-and-add-sound-hardware-abstraction.patch \
+    ${perfFIX} \
 "
-# This can fix a compilation issue with perf. This seems to collide with the cogent layer
-# so for now just don't apply and see if or where we need this.
-#    file://9999-perf-libbft-upstream.patch \
-#
 
 # For Xen
 SRC_URI_append = " \