Convert to new override syntax
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-graphics / wayland / weston-ini-conf.bbappend
index de8d955..4a76dda 100644 (file)
@@ -1 +1,15 @@
-WESTONCORE[repaint-window] ??= "34"
+FILESEXTRAPATHS:prepend:rcar-gen3 := "${THISDIR}/${PN}:"
+
+SRC_URI:append:rcar-gen3 = " \
+       file://kingfisher_output.cfg \
+       file://ebisu_output.cfg \
+       file://salvator-x_output.cfg \
+"
+
+WESTON_FRAGMENTS:append:ulcb = " kingfisher_output"
+WESTON_FRAGMENTS:append:ebisu = " ebisu_output"
+WESTON_FRAGMENTS:append:salvator-x = " salvator-x_output"
+
+do_configure:append:rcar-gen3() {
+    echo repaint-window=34 >> ${WORKDIR}/core.cfg
+}