meta-agl-core: Revise weston-ini-conf mechanism
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-graphics / wayland / weston-ini-conf.bbappend
index 44615c3..2fd50c3 100644 (file)
@@ -1,12 +1,15 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend_rcar-gen3 := "${THISDIR}/${PN}:"
 
-SRC_URI_append_ulcb = " file://kingfisher_output.cfg"
-SRC_URI_append_ebisu = " file://ebisu_output.cfg"
-SRC_URI_append_salvator-x = " file://salvator-x_output.cfg"
+SRC_URI_append_rcar-gen3 = " \
+       file://kingfisher_output.cfg \
+       file://ebisu_output.cfg \
+       file://salvator-x_output.cfg \
+"
 
-do_configure() {
-    echo repaint-window=34 >> ${WORKDIR}/core.cfg
+WESTON_FRAGMENTS_append_ulcb = " kingfisher_output"
+WESTON_FRAGMENTS_append_ebisu = " ebisu_output"
+WESTON_FRAGMENTS_append_salvator-x = " salvator-x_output"
 
-    echo transition-duration=300 >> ${WORKDIR}/ivishell.cfg
-    echo cursor-theme=default >> ${WORKDIR}/ivishell.cfg
+do_configure_append_rcar-gen3() {
+    echo repaint-window=34 >> ${WORKDIR}/core.cfg
 }