weston-ivi-extension: add focus notification patch
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-bsp / u-boot / u-boot_2015.04.bbappend
index 36d8c24..f627190 100644 (file)
@@ -1,9 +1,16 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot:"
 
 SRC_URI_append = " \
-    file://0001-fixup-build-with-gcc6.patch \
+    file://0001-fixup-build-with-gcc7.patch \
 "
 
+# Config names have changed in mainline u-boot since 2015.04,
+#  here we want to use the old ones.
+UBOOT_MACHINE = "${BOARD_NAME}_defconfig"
+
+# Also override the override
+UBOOT_MACHINE_sota = "${BOARD_NAME}_defconfig"
+
 do_deploy_prepend() {
-    ln -s ${B}/${UBOOT_SREC} ${S}/${UBOOT_SREC}
+    ln -sf ${B}/${UBOOT_SREC} ${S}/${UBOOT_SREC}
 }