Enable agl-sota for h3ulcb
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-bsp / u-boot / u-boot_2015.04.bbappend
index 6f30fa1..f627190 100644 (file)
@@ -4,6 +4,13 @@ SRC_URI_append = " \
     file://0001-fixup-build-with-gcc7.patch \
 "
 
+# Config names have changed in mainline u-boot since 2015.04,
+#  here we want to use the old ones.
+UBOOT_MACHINE = "${BOARD_NAME}_defconfig"
+
+# Also override the override
+UBOOT_MACHINE_sota = "${BOARD_NAME}_defconfig"
+
 do_deploy_prepend() {
     ln -sf ${B}/${UBOOT_SREC} ${S}/${UBOOT_SREC}
 }