fix gcc 6 build
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-bsp / u-boot / u-boot_2015.04.bbappend
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bbappend
new file mode 100644 (file)
index 0000000..36d8c24
--- /dev/null
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot:"
+
+SRC_URI_append = " \
+    file://0001-fixup-build-with-gcc6.patch \
+"
+
+do_deploy_prepend() {
+    ln -s ${B}/${UBOOT_SREC} ${S}/${UBOOT_SREC}
+}