weston-ini-conf: (re)move Weston remoting support
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-bsp / optee / optee-user-app-template_git.bb
index d66060b..2b93af7 100644 (file)
@@ -1,6 +1,6 @@
 SUMMARY = "OP-TEE user_app_template"
 
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
 LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=cd95ab417e23b94f381dafc453d70c30"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -12,7 +12,7 @@ PV = "0.1+git${SRCPV}"
 SRCREV = "0.1"
 
 SRC_URI = " \
-    git://github.com/iotbzh/optee_user_app_template;branch=master \
+    git://github.com/iotbzh/optee_user_app_template;branch=master;protocol=https \
 "
 
 COMPATIBLE_MACHINE = "(salvator-x|h3ulcb|m3ulcb|m3nulcb|ebisu)"
@@ -24,7 +24,7 @@ CFLAGS += "-Wno-extra -Wno-error=format"
 TARGET_CFLAGS += "-Wno-extra -Wno-error=format"
 
 TARGET_CC_ARCH += "${LDFLAGS}"
-INSANE_SKIP_${PN} = "ldflags"
+INSANE_SKIP:${PN} = "ldflags"
 
 TA_DEV_KIT_DIR = "${STAGING_DIR_TARGET}/usr/share/optee/export-ta_arm64"
 
@@ -54,4 +54,4 @@ do_install () {
     install -D -p -m0444 ${S}/out/ta/* ${D}${nonarch_base_libdir}/optee_armtz
 }
 
-FILES_${PN} += "${nonarch_base_libdir}/optee_armtz/"
+FILES:${PN} += "${nonarch_base_libdir}/optee_armtz/"