weston-ini-conf: (re)move Weston remoting support
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-bsp / optee / optee-test_git.bb
index 80a22b8..b66f067 100644 (file)
@@ -1,6 +1,6 @@
 DESCRIPTION = "OP-TEE TEST"
 
-LICENSE = "GPLv2 & BSD-2-Clause"
+LICENSE = "GPL-2.0-only & BSD-2-Clause"
 LIC_FILES_CHKSUM = "file://${S}/host/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -12,7 +12,7 @@ PV = "3.1.0+git${SRCPV}"
 SRCREV = "45218eb59b006ad20cc7610904f291dd85157a43"
 
 SRC_URI = " \
-    git://github.com/OP-TEE/optee_test.git;branch=master;name=master \
+    git://github.com/OP-TEE/optee_test.git;branch=master;name=master;protocol=https \
     file://optee_xtest_fix.diff \
 "
 
@@ -34,7 +34,7 @@ CFLAGS += "-Wno-extra -Wno-error=stringop-overflow -Wno-error=array-bounds"
 TARGET_CFLAGS += "-Wno-extra -Wno-error=stringop-overflow -Wno-error=array-bounds"
 
 TARGET_CC_ARCH += "${LDFLAGS}"
-INSANE_SKIP_${PN} = "ldflags"
+INSANE_SKIP:${PN} = "ldflags"
 
 S = "${WORKDIR}/git"
 EXTRA_OEMAKE = "-e MAKEFLAGS="
@@ -52,4 +52,4 @@ do_install () {
     install -D -p -m0444 ${S}/out/ta/*/*.ta ${D}${nonarch_base_libdir}/optee_armtz/
 }
 
-FILES_${PN} += "${nonarch_base_libdir}/optee_armtz/"
+FILES:${PN} += "${nonarch_base_libdir}/optee_armtz/"