Update github.com git:// SRC_URIs
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-bsp / optee / optee-os_git.bbappend
index 4845dda..77eeab9 100644 (file)
@@ -1,10 +1,7 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-inherit pythonnative
-DEPENDS += " python-pycrypto-native"
+do_install() {
+    install -d ${D}/usr/share/optee
+    cp -r ${S}/out/arm-plat-${PLATFORM}/export-ta_arm64 ${D}/usr/share/optee
+}
 
-#Need for gcc 6.2
-CFLAGS += " -fno-strict-aliasing -Wno-unused-variable -Wno-shift-negative-value"
-
-SRC_URI += " \
-        file://0001-disable-libgcc-detection.patch \
-"
+FILES_${PN}-staticdev += "${datadir}/optee/export-ta_arm64/lib/*.a"
+FILES_${PN}-dev += "${datadir}/optee/export-ta_arm64"