fix build with gcc6
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-bsp / optee / optee-os_git.bbappend
index 90d6717..4845dda 100644 (file)
@@ -1,4 +1,9 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+inherit pythonnative
+DEPENDS += " python-pycrypto-native"
+
+#Need for gcc 6.2
+CFLAGS += " -fno-strict-aliasing -Wno-unused-variable -Wno-shift-negative-value"
 
 SRC_URI += " \
         file://0001-disable-libgcc-detection.patch \