Enable cve-check in CI jobs for additional cve log files
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-bsp / arm-trusted-firmware / arm-trusted-firmware_git.bbappend
index cdfb3cb..f4d0869 100644 (file)
@@ -1,5 +1,9 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+# Boot Normal World in EL2: this define configures ATF (SPSR register) to boot
+# BL33 in EL2.
+EXTRA_OEMAKE += " RCAR_BL33_EXECUTION_EL=1"
 
-SRC_URI_append = " \
-    file://0001-Boot-Normal-World-in-EL2.patch \
-"
+do_ipl_opt_deploy:prepend () {
+    # Work around bug in BSP recipe, it can fail if nothing else has
+    # happened to run first and create the directory.
+    install -d ${DEPLOY_DIR_IMAGE}
+}