[RCAR] Fixed the unrecomennd operator usage
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-bsp / arm-trusted-firmware / arm-trusted-firmware_git.bbappend
index 8c6ebbf..212c661 100644 (file)
@@ -1,5 +1,11 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
 
-SRC_URI += " \
-    file://0001-fix-arm-trusted-firmware-build-for-gcc6.patch \
-    "
+SRC_URI:append = " \
+    file://0001-Boot-Normal-World-in-EL2.patch \
+"
+
+do_ipl_opt_deploy:prepend () {
+    # Work around bug in BSP recipe, it can fail if nothing else has
+    # happened to run first and create the directory.
+    install -d ${DEPLOY_DIR_IMAGE}
+}