Apply bluetooth/smack patches also to rpi kernel
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-kernel / linux / linux-raspberrypi_4.4.bbappend
index e5cdb2a..a2b2a42 100644 (file)
@@ -8,6 +8,18 @@ SRC_URI_append = "\
        ${@base_conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
 "
 
+#-------------------------------------------------------------------------
+# smack patches for handling bluetooth
+
+SRC_URI_append_smack = "\
+       file://0001-Smack-File-receive-for-sockets.patch \
+       file://0002-smack-fix-cache-of-access-labels.patch \
+       file://0003-Smack-ignore-null-signal-in-smack_task_kill.patch \
+       file://0004-Smack-Assign-smack_known_web-label-for-kernel-thread.patch \
+"
+
+
+
 do_configure_append_smack() {
     # SMACK and Co
     kernel_configure_variable IP_NF_SECURITY m