Apply bluetooth/smack patches also to rpi kernel
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-kernel / linux / linux-raspberrypi_4.4.bbappend
index f7b12e0..a2b2a42 100644 (file)
@@ -8,6 +8,18 @@ SRC_URI_append = "\
        ${@base_conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
 "
 
+#-------------------------------------------------------------------------
+# smack patches for handling bluetooth
+
+SRC_URI_append_smack = "\
+       file://0001-Smack-File-receive-for-sockets.patch \
+       file://0002-smack-fix-cache-of-access-labels.patch \
+       file://0003-Smack-ignore-null-signal-in-smack_task_kill.patch \
+       file://0004-Smack-Assign-smack_known_web-label-for-kernel-thread.patch \
+"
+
+
+
 do_configure_append_smack() {
     # SMACK and Co
     kernel_configure_variable IP_NF_SECURITY m
@@ -44,6 +56,16 @@ do_configure_append() {
     kernel_configure_variable DRM_VC4 y
     kernel_configure_variable FB_BCM2708 n
 
+    # Enable support for TP-Link TL-W722N USB Wifi adapter
+    kernel_configure_variable CONFIG_ATH_CARDS m
+    kernel_configure_variable CONFIG_ATH9K_HTC m
+
+    # Enable support for RTLSDR
+    kernel_configure_variable CONFIG_MEDIA_USB_SUPPORT y
+    kernel_configure_variable CONFIG_MEDIA_DIGITAL_TV_SUPPORT y
+    kernel_configure_variable CONFIG_DVB_USB_V2 m
+    kernel_configure_variable CONFIG_DVB_USB_RTL28XXU m
+
     # KEEP until fixed upstream:
       # Keep this the last line
       # Remove all modified configs and add the rest to .config
@@ -53,9 +75,12 @@ do_configure_append() {
       kernel_do_configure
 }
 
-
+CMDLINE_DEBUG = ""
 CMDLINE_append = " usbhid.mousepoll=0"
 
+# Add options to allow CMA to operate
+CMDLINE_append = ' ${@base_conditional("ENABLE_CMA", "1", "coherent_pool=6M smsc95xx.turbo_mode=N", "", d)}'
+
 KERNEL_MODULE_AUTOLOAD += "snd-bcm2835"
 KERNEL_MODULE_AUTOLOAD += "hid-multitouch"