raspberrypi-linux: add smack patchset to 4.9 bbappend
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-kernel / linux / linux-raspberrypi_4.4.bbappend
index 8c00735..9879c6f 100644 (file)
@@ -1,18 +1,9 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
-
-LINUX_VERSION = "4.4.16"
-
-SRCREV = "26550dcfb86b0308a99f726abbfb55abb1b0f78c"
-
-SRC_URI_append = "\
-       file://0001-rpi-defconfig.patch \
-       ${@base_conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
+#-------------------------------------------------------------------------
+# smack patches for handling bluetooth
+
+SRC_URI_append_smack = "\
+       file://0001-Smack-File-receive-for-sockets.patch \
+       file://0002-smack-fix-cache-of-access-labels.patch \
+       file://0003-Smack-ignore-null-signal-in-smack_task_kill.patch \
+       file://0004-Smack-Assign-smack_known_web-label-for-kernel-thread.patch \
 "
-
-CMDLINE_append = " usbhid.mousepoll=0"
-
-KERNEL_MODULE_AUTOLOAD += "snd-bcm2835"
-KERNEL_MODULE_AUTOLOAD += "hid-multitouch"
-
-RDEPENDS_${PN} += "kernel-module-snd-bcm2835"
-PACKAGES += "kernel-module-snd-bcm2835"