Raspberry 4: XEN support
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-kernel / linux / linux-raspberrypi_4.19.bbappend
index cc9bcad..7f17f0c 100644 (file)
@@ -1,9 +1,20 @@
-# Update Linux kernel for Raspberry Pi to 4.19.80. This version
-# allows to run firmware KMS to support output through HDMI and
-# DSI for the official 7" Raspberry Pi touch screen display.
-# Bug-AGL: SPEC-2465
-LINUX_VERSION = "4.19.80"
-SRCREV = "3492a1b003494535eb1b17aa7f258469036b1de7"
+require recipes-kernel/linux/linux-agl-4.19.inc
 
 ENABLE_UART_raspberrypi4 = "1"
 
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+
+# For Xen
+
+SRC_URI_append =" \
+    ${@bb.utils.contains('AGL_XEN_WANTED','1','file://0002-Disable-DMA-in-sdhci-driver.patch','',d)} \
+"
+
+SRC_URI_append =" \
+    ${@bb.utils.contains('AGL_XEN_WANTED','1','file://0003-Fix-PCIe-in-dom0-for-RPi4.patch','',d)} \
+"
+
+SRC_URI_append = " \
+    ${@bb.utils.contains('AGL_XEN_WANTED','1','file://xen-be.cfg','',d)} \
+"