Revert "meta-agl-bsp: meta-sancloud: Revert problematic kernel commit"
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-kernel / linux / linux-raspberrypi_%.bbappend
index 1db6d42..ec3fa91 100644 (file)
@@ -1,72 +1,46 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
 
-SRC_URI_append = "\
-       ${@base_conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
-"
+require recipes-kernel/linux/linux-yocto-agl.inc
 
-do_configure_append_smack() {
-    # SMACK and Co
-    kernel_configure_variable IP_NF_SECURITY m
-    kernel_configure_variable IP6_NF_SECURITY m
-    kernel_configure_variable EXT2_FS_SECURITY y
-    kernel_configure_variable EXT3_FS_SECURITY y
-    kernel_configure_variable EXT4_FS_SECURITY y
-    kernel_configure_variable SECURITY y
-    kernel_configure_variable SECURITY_SMACK y
-    kernel_configure_variable TMPFS_XATTR y
-    kernel_configure_variable DEFAULT_SECURITY "smack"
-    kernel_configure_variable DEFAULT_SECURITY_SMACK y
-    kernel_configure_variable FANOTIFY_ACCESS_PERMISSIONS y
-}
+SRC_URI:append = " \
+    ${@oe.utils.conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
+    file://0001-mconf-menuconfig.patch \
+"
 
-do_configure_append_netboot() {
-    # NBD for netboot
-    kernel_configure_variable BLK_DEV_NBD y
-    # ramblk for inird
-    kernel_configure_variable BLK_DEV_RAM y
-}
+# Enable support for Pi foundation touchscreen
+AGL_KCONFIG_FRAGMENTS += "raspberrypi-panel.cfg"
 
-do_configure_append_sota() {
-    # ramblk for inird
-    kernel_configure_variable BLK_DEV_RAM y
-}
+# Enable bt hci uart
+AGL_KCONFIG_FRAGMENTS += "raspberrypi-hciuart.cfg"
 
-do_configure_append() {
+# ENABLE NETWORK (built-in)
+AGL_KCONFIG_FRAGMENTS += "raspberrypi_network.cfg"
 
-    # VC4 Wayland/Weston
-    kernel_configure_variable I2C_BCM2835 y
-    kernel_configure_variable DRM y
-    kernel_configure_variable DRM_PANEL_RASPBERRYPI_TOUCHSCREEN y
-    kernel_configure_variable DRM_VC4 y
-    kernel_configure_variable FB_BCM2708 n
+# For Xen
+AGL_KCONFIG_FRAGMENTS += " \
+    ${@bb.utils.contains('AGL_XEN_WANTED','1','xen-be.cfg','',d)} \
+"
 
-    # Enable support for TP-Link TL-W722N USB Wifi adapter
-    kernel_configure_variable CONFIG_ATH_CARDS m
-    kernel_configure_variable CONFIG_ATH9K_HTC m
+# Take in account that linux under Xen should use the hvc0 console
+SERIAL_OPTION = "${@bb.utils.contains('AGL_XEN_WANTED','1','hvc0','ttyS0,115200',d)}"
+SERIAL = "${@oe.utils.conditional("ENABLE_UART", "1", "console=${SERIAL_OPTION}", "", d)}"
 
-    # Enable support for RTLSDR
-    kernel_configure_variable CONFIG_MEDIA_USB_SUPPORT y
-    kernel_configure_variable CONFIG_MEDIA_DIGITAL_TV_SUPPORT y
-    kernel_configure_variable CONFIG_DVB_USB_V2 m
-    kernel_configure_variable CONFIG_DVB_USB_RTL28XXU m
+CMDLINE_DEBUG = ""
 
-    # KEEP until fixed upstream:
-      # Keep this the last line
-      # Remove all modified configs and add the rest to .config
-      sed -e "${CONF_SED_SCRIPT}" < '${WORKDIR}/defconfig' >> '${B}/.config'
+# Xen related option
+CMDLINE:append = ' ${@bb.utils.contains('AGL_XEN_WANTED','1','clk_ignore_unused','',d)}'
 
-      yes '' | oe_runmake oldconfig
-      kernel_do_configure
-}
+# Workaround for crash during brcmfmac loading. Disable it at this moment
+CMDLINE:append = ' ${@bb.utils.contains('AGL_XEN_WANTED','1','modprobe.blacklist=brcmfmac','',d)}'
 
-CMDLINE_DEBUG = ""
-CMDLINE_append = " usbhid.mousepoll=0"
+CMDLINE:append = " usbhid.mousepoll=0"
 
 # Add options to allow CMA to operate
-CMDLINE_append = ' ${@base_conditional("ENABLE_CMA", "1", "coherent_pool=6M smsc95xx.turbo_mode=N", "", d)}'
+CMDLINE:append = '${@oe.utils.conditional("ENABLE_CMA", "1", " coherent_pool=6M smsc95xx.turbo_mode=N", "", d)}'
 
 KERNEL_MODULE_AUTOLOAD += "snd-bcm2835"
 KERNEL_MODULE_AUTOLOAD += "hid-multitouch"
 
-RDEPENDS_${PN} += "kernel-module-snd-bcm2835"
 PACKAGES += "kernel-module-snd-bcm2835"
+
+RDEPENDS:${PN} += "kernel-module-snd-bcm2835"