Backport fix for image class dependencies
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-kernel / linux / linux-raspberrypi_%.bbappend
index 6557ce0..753440a 100644 (file)
@@ -1,17 +1,9 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
 
 SRC_URI_append = "\
-       ${@base_conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
+    ${@base_conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
 "
 
-# Fix CVE-2017-1000364
-SRC_URI_append = "\
-      file://0001-mm-larger-stack-guard-gap-between-vmas.patch \
-      file://0002-Allow-stack-to-grow-up-to-address-space-limit.patch \
-      file://0003-mm-fix-new-crash-in-unmapped_area_topdown.patch \
-"
-
-
 do_configure_append_smack() {
     # SMACK and Co
     kernel_configure_variable IP_NF_SECURITY m
@@ -111,3 +103,6 @@ KERNEL_MODULE_AUTOLOAD += "hid-multitouch"
 
 RDEPENDS_${PN} += "kernel-module-snd-bcm2835"
 PACKAGES += "kernel-module-snd-bcm2835"
+
+# Enable support for usb video class for usb camera devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"