Fix CVE-2017-1000364 by backporting the patches for rpi3
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-kernel / linux / linux-raspberrypi_%.bbappend
index 8417982..6557ce0 100644 (file)
@@ -4,6 +4,14 @@ SRC_URI_append = "\
        ${@base_conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
 "
 
+# Fix CVE-2017-1000364
+SRC_URI_append = "\
+      file://0001-mm-larger-stack-guard-gap-between-vmas.patch \
+      file://0002-Allow-stack-to-grow-up-to-address-space-limit.patch \
+      file://0003-mm-fix-new-crash-in-unmapped_area_topdown.patch \
+"
+
+
 do_configure_append_smack() {
     # SMACK and Co
     kernel_configure_variable IP_NF_SECURITY m