meta-agl-bsp: clean up Raspberry Pi Xen support
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-kernel / linux / linux-raspberrypi_%.bbappend
index ffbf791..5069e1e 100644 (file)
@@ -1,29 +1,33 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
 
 require recipes-kernel/linux/linux-agl.inc
-require recipes-kernel/linux/linux-agl-4.14.inc
-
-# ENABLE DSI
-# ported from https://github.com/k-quigley/linux
-SRC_URI_append = " \
-    file://dsi/0001-Add-devicetree-support-for-RaspberryPi-7-panel-over-.patch \
-    file://dsi/0002-drm-vc4-Make-DSI-call-into-the-bridge-after-the-DSI-.patch \
-    file://dsi/0003-drm-vc4-Set-up-the-DSI-host-at-pdev-probe-time-not-c.patch \
-    file://dsi/0004-drm-panel-Backport-4.15-support-for-the-Raspberry-Pi.patch \
-"
 
-# NOTE: Kprobes need to be disabled until linux-raspberrypi gets updated
-#       to newer than 4.14.104 to avoid lttng-modules failing to build.
 SRC_URI_append = "\
     ${@oe.utils.conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
-    file://disable_kprobes.cfg \
+    file://0001-mconf-menuconfig.patch \
+"
+
+# For Xen
+SRC_URI_append = "\
+    ${@bb.utils.contains('AGL_XEN_WANTED','1','file://xen-be.cfg','',d)} \
 "
 
+#take in account that linux under xen should use the hvc0 console
+SERIAL_OPTION = "${@bb.utils.contains('AGL_XEN_WANTED','1','hvc0','ttyS0,115200',d)}"
+SERIAL = "${@oe.utils.conditional("ENABLE_UART", "1", "console=${SERIAL_OPTION}", "", d)}"
+
 CMDLINE_DEBUG = ""
+
+# XEN related option
+CMDLINE_append = ' ${@bb.utils.contains('AGL_XEN_WANTED','1','clk_ignore_unused','',d)}'
+
+# Workaround for crash during brcmfmac loading. Disable it at this moment
+CMDLINE_append = ' ${@bb.utils.contains('AGL_XEN_WANTED','1','modprobe.blacklist=brcmfmac','',d)}'
+
 CMDLINE_append = " usbhid.mousepoll=0"
 
 # Add options to allow CMA to operate
-CMDLINE_append = ' ${@oe.utils.conditional("ENABLE_CMA", "1", "coherent_pool=6M smsc95xx.turbo_mode=N", "", d)}'
+CMDLINE_append = '${@oe.utils.conditional("ENABLE_CMA", "1", " coherent_pool=6M smsc95xx.turbo_mode=N", "", d)}'
 
 KERNEL_MODULE_AUTOLOAD += "snd-bcm2835"
 KERNEL_MODULE_AUTOLOAD += "hid-multitouch"