meta-agl-bsp: clean up Raspberry Pi Xen support
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-kernel / linux / linux-raspberrypi_%.bbappend
index dd85066..5069e1e 100644 (file)
@@ -6,16 +6,22 @@ SRC_URI_append = "\
     ${@oe.utils.conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
     file://0001-mconf-menuconfig.patch \
 "
+
+# For Xen
+SRC_URI_append = "\
+    ${@bb.utils.contains('AGL_XEN_WANTED','1','file://xen-be.cfg','',d)} \
+"
+
 #take in account that linux under xen should use the hvc0 console
-SERIAL_OPTION = "${@bb.utils.contains('AGL_XEN_WANTED','1','hvc0','115200;ttyS0',d)}"
+SERIAL_OPTION = "${@bb.utils.contains('AGL_XEN_WANTED','1','hvc0','ttyS0,115200',d)}"
 SERIAL = "${@oe.utils.conditional("ENABLE_UART", "1", "console=${SERIAL_OPTION}", "", d)}"
 
 CMDLINE_DEBUG = ""
 
-#XEN related option
+# XEN related option
 CMDLINE_append = ' ${@bb.utils.contains('AGL_XEN_WANTED','1','clk_ignore_unused','',d)}'
 
-#workaround for crash during brcmfmac loading. Disable it at this moment
+# Workaround for crash during brcmfmac loading. Disable it at this moment
 CMDLINE_append = ' ${@bb.utils.contains('AGL_XEN_WANTED','1','modprobe.blacklist=brcmfmac','',d)}'
 
 CMDLINE_append = " usbhid.mousepoll=0"