Raspberry 4: XEN support
[AGL/meta-agl.git] / meta-agl-bsp / meta-raspberrypi / recipes-bsp / bootfiles / rpi-config_git.bbappend
index 5eecff6..9891fa2 100644 (file)
@@ -1,4 +1,5 @@
 DISABLE_OVERSCAN = "1"
+TOTAL_BOARD_MEM = "3072"
 
 do_deploy_append_raspberrypi4() {
     # ENABLE CAN
@@ -17,6 +18,10 @@ do_deploy_append_raspberrypi4() {
                 ;;
         esac
     fi
+
+    if [ "${AGL_XEN_WANTED}" = "1" ]; then
+        echo "total_mem=${TOTAL_BOARD_MEM}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+    fi
 }
 
 do_deploy_append() {