adding Minnow eth driver to allow network boot
[AGL/meta-agl.git] / meta-agl-bsp / meta-intel / recipes-kernel / linux / linux-intel_4.9%.bbappend
index d524ebf..7f249f2 100644 (file)
@@ -1,5 +1,7 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
 
+require recipes-kernel/linux/linux-agl-4.9.inc
+
 # adding most supported USB Bluetooth, Wifi, and Ethernet devices
 SRC_URI_append = " file://usb-devices.cfg"
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/usb-devices.cfg"
@@ -8,5 +10,13 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/usb-devices.cfg"
 SRC_URI_append = " file://extra-graphic-devices.cfg"
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/extra-graphic-devices.cfg"
 
-# Enable support for usb video class for usb camera devices
-KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
+# adding internal network in kernel for network boot
+SRC_URI_append = " file://net-devices.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/net-devices.cfg"
+
+# Ensure we have a startup.nsh file
+SRC_URI_append = " file://startup.nsh"
+
+do_deploy_append() {
+       install -m 0755 ${WORKDIR}/startup.nsh ${DEPLOYDIR}/
+}