Rework Linux Kernel fragment applications
[AGL/meta-agl.git] / meta-agl-bsp / meta-intel / recipes-kernel / linux / linux-intel_4.9%.bbappend
index ce600f5..361abad 100644 (file)
@@ -1,5 +1,7 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
 
+require recipes-kernel/linux/linux-agl-4.9.inc
+
 # adding most supported USB Bluetooth, Wifi, and Ethernet devices
 SRC_URI_append = " file://usb-devices.cfg"
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/usb-devices.cfg"
@@ -8,12 +10,6 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/usb-devices.cfg"
 SRC_URI_append = " file://extra-graphic-devices.cfg"
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/extra-graphic-devices.cfg"
 
-# Enable support for usb video class for usb camera devices
-KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
-
-# Enable support for joystick devices
-KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"
-
 # Ensure we have a startup.nsh file
 SRC_URI_append = " file://startup.nsh"