adding a symlink to keep compatibility with linux-yocto
[AGL/meta-agl.git] / meta-agl-bsp / meta-intel / recipes-kernel / linux / linux-intel_4.9%.bbappend
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.9%.bbappend b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.9%.bbappend
new file mode 100644 (file)
index 0000000..d524ebf
--- /dev/null
@@ -0,0 +1,12 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+# adding most supported USB Bluetooth, Wifi, and Ethernet devices
+SRC_URI_append = " file://usb-devices.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/usb-devices.cfg"
+
+# adding support for other graphic cards to work on more PC HW
+SRC_URI_append = " file://extra-graphic-devices.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/extra-graphic-devices.cfg"
+
+# Enable support for usb video class for usb camera devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"