Refactor kernel configuration fragment handling
[AGL/meta-agl.git] / meta-agl-bsp / meta-freescale-layer / recipes-kernel / linux / linux-fslc_%.bbappend
index 640f9cf..95f764b 100644 (file)
@@ -1,23 +1,20 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
 
-require recipes-kernel/linux/linux-agl.inc
+require recipes-kernel/linux/linux-yocto-agl.inc
 
-# Make sure these are enabled so that AGL configurations work
-SRC_URI_append = " file://tmpfs.cfg"
-KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/tmpfs.cfg"
-SRC_URI_append = " file://namespace.cfg"
-KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/namespace.cfg"
-SRC_URI_append = " file://cgroup.cfg"
-KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/cgroup.cfg"
+# Make sure these are enabled so that AGL systemd configuration works
+AGL_KCONFIG_FRAGMENTS += " \
+    tmpfs.cfg \
+    namespace.cfg \
+    cgroup.cfg \
+"
 
 # Support for CFG80211 subsystem
-SRC_URI_append = " file://cfg80211.cfg"
-KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/cfg80211.cfg"
+AGL_KCONFIG_FRAGMENTS += "cfg80211.cfg"
 
 # Turn off a couple of things enabled by default by Freescale
 # (lock debugging and userspace firmware loader fallback)
-SRC_URI_append = " file://fixups.cfg"
-KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/fixups.cfg"
+AGL_KCONFIG_FRAGMENTS += "fixups.cfg"
 
 do_install_append_cubox-i() {
     # Add symlink to work with default Hummingboard 2 u-boot configuration