meta-agl-bsp: NXP i.MX6 and i.MX8 fixes
[AGL/meta-agl.git] / meta-agl-bsp / meta-freescale-layer / recipes-kernel / linux / linux-fslc-imx_%.bbappend
index c6f60d3..7fa055b 100644 (file)
@@ -1,31 +1,16 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
 
-require recipes-kernel/linux/linux-yocto-agl.inc
+require linux-fslc.inc
 
 # These patches and the configuration fragment below will need to be
 # revisited if/when using IMX_DEFAULT_BSP = "mainline" with i.MX8
-# becomes more feasible with upstream meta-freescale.
-SRC_URI_append_etnaviv = " \
-    file://0001-enable-mhdp-with-etnaviv.patch \
-    file://0002-dts-enable-etnaviv.patch \
-"
-
-# Make sure these are enabled so that AGL systemd configuration works
-AGL_KCONFIG_FRAGMENTS += " \
-    tmpfs.cfg \
-    namespace.cfg \
-    cgroup.cfg \
-"
-
-# Support for CFG80211 subsystem
-AGL_KCONFIG_FRAGMENTS += "cfg80211.cfg"
-
-# Turn off a couple of things enabled by default by Freescale
-# (lock debugging and userspace firmware loader fallback)
-AGL_KCONFIG_FRAGMENTS += "fixups.cfg"
+# becomes feasible with the linux-fslc kernel.
+#SRC_URI:append:etnaviv = " \
+#    file://0002-dts-enable-etnaviv.patch \
+#"
 
 # Support for i.MX8MQ EVKB (e.g. Broadcom wifi)
-AGL_KCONFIG_FRAGMENTS_append_imx8mqevk = " imx8mq-evkb.cfg"
+AGL_KCONFIG_FRAGMENTS:append:imx8mq-evk = " imx8mq-evkb.cfg"
 
 # Build in etnaviv if required
-AGL_KCONFIG_FRAGMENTS_append_etnaviv = " etnaviv.cfg"
+AGL_KCONFIG_FRAGMENTS:append:etnaviv = " etnaviv.cfg"