Add imx8mqevk machine that uses etnaviv
[AGL/meta-agl.git] / meta-agl-bsp / meta-freescale-layer / recipes-kernel / linux / linux-fslc-imx_%.bbappend
index 33e72bf..549ba39 100644 (file)
@@ -1,7 +1,15 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:${THISDIR}/files:"
 
 require recipes-kernel/linux/linux-agl.inc
 
+# These patches and the configuration fragment below will need to be
+# revisited if/when using IMX_DEFAULT_BSP = "mainline" with i.MX8
+# becomes more feasible with upstream meta-freescale.
+SRC_URI_append_etnaviv = " \
+    file://0001-enable-mhdp-with-etnaviv.patch \
+    file://0002-dts-enable-etnaviv.patch \
+"
+
 # Make sure these are enabled so that AGL configurations work
 SRC_URI_append = " file://tmpfs.cfg"
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/tmpfs.cfg"
@@ -18,6 +26,10 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/cfg80211.cfg"
 SRC_URI_append_imx8mqevk = " file://imx8mq-evkb.cfg"
 KERNEL_CONFIG_FRAGMENTS_append_imx8mqevk = " ${WORKDIR}/imx8mq-evkb.cfg"
 
+# Build in etnaviv if required
+SRC_URI_append_etnaviv = " file://etnaviv.cfg"
+KERNEL_CONFIG_FRAGMENTS_append_etnaviv = " ${WORKDIR}/etnaviv.cfg"
+
 # Turn off a couple of things enabled by default by Freescale
 # (lock debugging and userspace firmware loader fallback)
 SRC_URI_append = " file://fixups.cfg"