Append kernel recipe to support config fragments and add common kernel config fragments
[AGL/meta-agl.git] / meta-agl-bsp / meta-boundary / recipes-kernel / linux / linux-boundary_4.1.15.bbappend
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend
new file mode 100644 (file)
index 0000000..e2996f9
--- /dev/null
@@ -0,0 +1,35 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+# Enable support for AR9271
+SRC_URI_append = " file://ath9k_htc.cfg"
+
+# Enable support for Bluetooth HCI USB devices
+SRC_URI_append = " file://btusb.cfg"
+
+# Enable support for Bluetooth HCI USB devices
+SRC_URI_append = " file://btusb.cfg"
+
+# Enable support for HID multitouch
+SRC_URI_append = " file://hid.cfg"
+
+# Enable support for RTLSDR
+SRC_URI_append = " file://rtl_sdr.cfg"
+
+# Set security default to SMACK
+SRC_URI_append = " file://smack.cfg"
+SRC_URI_append = " file://smack-default-lsm.cfg"
+
+# returns all the elements from the src uri that are .cfg files
+def find_cfgs(d):
+    sources=src_patches(d, True)
+    sources_list=[]
+    for s in sources:
+        if s.endswith('.cfg'):
+            sources_list.append(s)
+
+    return sources_list
+
+do_configure_prepend () { 
+    cp -a ${WORKDIR}/defconfig .config
+    merge_config.sh -m .config ${@" ".join(find_cfgs(d))} 
+}
\ No newline at end of file