systemd-udev: ensure convention for naming udev rules
[AGL/meta-agl.git] / meta-agl / recipes-ivi / images / agl-image-ivi.bb
index e14101e..dd4f89b 100644 (file)
@@ -1,16 +1,17 @@
 SUMMARY = "A basic system of AGL distribution of IVI profile"
 
-IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
+DESCRIPTION = "Basic image for baseline of AGL Distribution for IVI profile."
 
-LICENSE = "MIT"
+require agl-image-ivi.inc
 
-inherit core-image distro_features_check
+LICENSE = "MIT"
 
-REQUIRED_DISTRO_FEATURES = "wayland"
+IMAGE_INSTALL_append = "\
+    packagegroup-agl-image-ivi \
+    "
 
-CORE_IMAGE_BASE_INSTALL += "weston weston-init weston-examples"
+DISTRO_FEATURES_append = " agl-core-image-profile"
 
-IMAGE_INSTALL_append = "\
-    packagegroup-agl-core \
-    packagegroup-agl-ivi \
+IMAGE_INSTALL += "\
+    agl-desktop-config \
     "